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Abstract:  An earthquake is haphazard natural disaster that causes harm to lives and property. It happens all of a sudden and 

that we cannot stop it how ever we will be alerted from it. In the present time, there are numerous advancements which can be 

utilized to identify the little shakes and knocks of the earth. In order to prevent that we can take precautions before some major 

vibrations takes place within the earth. Lives can be saved by giving an early cautioning of earthquake. Here we are using 

analogue sensor detect the pre-earthquake vibrations using NODEMCU ESP8266 board. It connects to Thinkg Speak. If the 

device triggers a pre-determined threshold, Think speak  generates an SMS and EMAIL cautioning of an earthquake. 

Earthquake early-warning systems detect the first quivering of a major quake, triggering alarm systems in advance of the most 

violent shaking. The Alert system that has been proposed for all over the world would use a network of digital seismometers 

deployed around the state to give populated areas up to a minute of advance warning (depending on the location of the epicenter). 

The alerts would allow businesses, residents and public agencies time to get ready. The purpose of the study focuses on the 

detection algorithm using the collected data to decide if an earthquake is occurring. The algorithm is adaptive in nature and is 

based on a probabilistic approach over a sliding window to maximize the detection of events by adjusting the probability of false 

alarms under a fixed rate.  

 

Keywords: Earthquake warning system, embedded system, geological wireless sensor network, micro-electromechanical sensor, 

piezoelectric sensor, real-time seismology, Software installation of Arduino IDE 

I. INTRODUCTION  

        An earthquake could be a development ensuing from the sharp unleash of keep energy within the earth’s crust that creates seismic 

waves. These elastic waves radiate outward from the "source" and vibrate at the bottom. One of the foremost scary and damaging 

phenomena of nature could be a severe earthquake. For many lots of years, the forces of tectonics have formed the world because the 

immense plates that kind the layer slowly yield, under, and past one another. Typically the movement is gradual. At alternative times, the 

plates are locked together, unable to release the accumulating energy. Earthquakes represent one in every of the most important potential 

supply of casualties and injury for populous areas attributable to a natural hazard. Throughout history, they have destroyed innumerable 

cities and villages round the world and caused the death of thousands of individuals. As well as the threat that earthquakes create to life and 

property, the economic threat is additionally terribly vital. It’s useful to possess sensors as near to the geographic point as potential so the 

maximum amount warning may be provided as potential. This needs more number of sensors distributed over  

the earthquake affected zones. The project has created a prototype using a low cost sensor with the esp8266. It uses a SW-420 sensor which 

is sampled by the esp8266‟s 10-bit ADC. It connects to Think Speak to generate the cautioning to the people to E-mail. 

What is the Internet of Things?  

The Internet of Things connects the physical world to the Internet so that you can use data from devices to increase productivity and 

efficiency. Connecting things to the Internet is possible because different connectivity options are widely available, the cost of connecting 

is declining, and more devices are capturing data. All kinds of things are being used in Internet of Things applications including consumer 

products such as refrigerators, security cameras, and cable set-top boxes; industrial systems such as conveyor belts and manufacturing 
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equipment; and commercial devices such as traffic signals and smart meters. Any device that can be poweredoncould be part of an Internet 

of Things application. 

 

How does the Internet of Things work?  

 The Internet of Things was coined by Kevin Ashton, a British technology pioneer working on radio-frequency identification (RFID) who 

conceived a system of ubiquitous sensors connecting the physical world to the Internet. Today, the Internet of Things connects physical  

devices embedded with electronics, software, sensors, and actuators to the cloud and to each other. Devices communicate through different 

protocols and many, such as Message Queuing Telemetry Transport (MQTT) , were designed to tolerate intermittent connections and 

reduce network bandwidth requirements. All Internet of Things communication must be secured using preventive security mechanisms and 

best practices, like device identity management, encryption, and access control as well as device auditing and monitoring. Although 

connected things, the Internet, and secure connectivity are required to create Internet of Things applications, the value is in closing the gap 

between the physical and digital world in self-reinforcing and self-improving 

 

Why is the Internet of Things important?  

The Internet of Things is important because it makes previously unusable data available. Internet of Things applications tap into device 

data and let you visualize, explore, and build sophisticated analytics such as machine learning in the cloud. Internet of Things applications 

can also run on devices so they can respond in real-time as events unfold. For example, a predictive model for scene detection analysis 

could run on a security camera and, when the camera sees suspicious activity, it could send an alert. Internet of Things applications are 

deployed across a wide range of use cases including  homes,   connected   vehicles,   healthcare,   industrial, retail,   and   many  more 

connected homes are   safer,   cleaner,   and   more   energy efficient.For example, am way has successfully launched its first Internet-

connected product—the Atmosphere Sky Air Treatment System using AWS Internet of Things to build policies and security throughout 

the entire architecture.  

Internet of Things applications are used for industrial use cases to improve processes, create new revenue streams, reduce costs, and increase 

safety by analyzing data from equipment, creating predictive maintanance models, and keeping devices up to date with over-the-air updates. 

For example, Emergency Medical Service uses AWS Internet of Things to detect fuel leaks early to minimize environmental impact. 

Emergency Medical Service delivered a 500% Return of Internet using like LED lights and fans are also connected to make the home 

energy efficient. The proposed system is 

  

 
 

Fig-1-Basic Functional Block diagram 
 

2. HARDWARE DESIGN 

 

 The proposed disaster management system using internet of things in smart cities, the block diagram gives details of NodeMCU board 

along with Esp8266 wifi-module collects the data from the various sensors  DTH11 module,sensor,  Sensors give input to the module by 

sensing the atmospheric conditions. The Arduino programming environment facilitates the developer to manage, compile, upload, and 

simulate programs in a user friendly environment.  

A Wifi-module ESP8266 is low-code MCU supports Wi-Fi and the HTTP protocol, thus enabling to connect the board to the Internet 

without a gateway solution and merge it into complex device networks made up of smart sensors. The sensed data is stored in cloud. 

"ThingSpeak is an open source Internet of Things (IOT) application and API to store and retrieve data from things using the HTTP protocol 

over the Internet or via a Local Area Network. ThingSpeak enables the creation of sensor logging applications. Modules switch to the 

disaster management mode when they receive the alert signal and information is sent to rescue agencies via Gmail, and people of that 

particular region the module is operating through telegram application, messages of information is sent in specified group. Monitor is used 

to observe the readings from the sensed data of module. ThingView is the mobile application used view the sensors data stored in 

ThingSpeak. During extreme temperature, Fan is switched on automatically,and in case of fire disaster sprinklers are made on. But some 

of the natural disaster like flood and earthquake are analyzed prior and informed via   mail and sms.    
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 2.1 NODE-MCU  

 

 ESP8266 Node-MCU WiFi Devkit:-  

The ESP8266 is the name of a micro controller designed by Espressif Systems. The ESP8266 itself is a self-contained WiFi networking 

solution offering as a bridge from existing micro controller to WiFi and is also capable of running self-contained applications. This module 

comes with a built in USB connector and a rich assortment of pin-outs. With a micro USB cable, you can connect NodeMCU devkit to 

your laptop and flash it without any trouble, just like Arduino. It is also immediately breadboard friendly.    

features   

• An open source ESP8266 firmware that is built on top of the chip.  

• Manufacturer's proprietary SDK. The firmware provides a simple programming environment based on eLua (embedded Lua), which is a 

very simple And fast scripting language with an established developer community.  

• For new comers, the Lua scripting language is easy to learn. Arduino like hardware I/O Event driven API for network applications 10 

GPIOs D0-D10, PWM functionality, IIC and SPI communication, 1- Wire and    ADC A0 etc. all in one board  USB-TTL included, plug 

and play.      

 

     Specification:  

     • Voltage: 3.3V.  

     • Wi-Fi Direct (P2P), soft-AP.  

     • Current consumption: 10uA~170mA.   

     • Flash memory attachable: 16MB max (512K normal).  

     • Integrated TCP/IP protocol stack.   

     • Processor: Ten silica L106 32-bit.   

     • Processor speed: 80~160MHz.  

     • RAM: 32K + 80K.   

     • GPIOs: 17 (multiplexed with other functions). 

     • Analogue to Digital: 1 input with 1024 step resolution.  

     • +19.5dBm output power in 802.11b mode   

     • 802.11 support: b/g/n.  

     • Maximum concurrent TCP connections:5 

 

 
 
 
 
 
 
 
 
 
 
 
 

 

     PIN- Description:-   

The NodeMCU (Node Microcontroller Unit) is open source software and hardware development atmosphere that is engineered around 

a System-on-a-Chip (SoC) referred to as the ESP8266. The ESP8266, designed and created by Espressif Systems, contains all crucial 

components of a computer: electronic equipment, RAM, networking (wifi), and even a modern operating system and SDK. The 

Development Kit supported eLua primarily based code for the ESP8266 Wi-Fi SOC from Espressif, integrates GPIO, PWM, IIC, 1-

Wire and ADC all in one board. And hardware that is predicated on the ESP-12 module. The firmware uses the Lua scripting language. 
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2.2 DHT 11 Humidity & Temperature Sensor:- 
 

DHT11 Temperature & Humidity Sensor features 

 a temperature & humidity sensor complex with a calibrated digital signal output. By using the exclusive digital-signal-acquisition technique 

and temperature & humidity sensing technology, it ensures high reliability and excellent long-term stability. This sensor includes a resistive-

type humidity measurement component and an NTC temperature measurement component, and connects to a high performance 8-bit 

microcontroller, offering excellent quality, fast response, anti-interference ability and cost-effectiveness. 

  

2.2.1 Power and Pin 
 

DHT11’s power supply is 3-5.5V DC. When power is supplied to the sensor, do not send any instruction to the sensor in within one second 

in order to pass the unstable status. One Capacitor valued 100nF can be added between VDD and GND(Ground) for power filtering. 

                                                                                  

 

 

 

 

 

 

 

 

 

 

 

 2.2.3 Vibration Sensor 
 

 This module features an adjustable potentiometer, a    vibration sensor, and a LM393 comparator chip to give an  adjustable digital output 

based on the amount of vibration.  The potentiometer can be adjusted to both increase and decrease the sensitivity to the desired amount. 

The module outputs a logic level high (VCC) when it is triggered and a low (GND) when it isn’t. Additionally there is an onboard Light 

Emitted Diode that turns on when the module is triggered. 

 

            

 

 

 

 

 

 

 

 

 

 

 

 

 

  Features 
 

 The default state of the switch is close.

 Digital output Supply voltage: 3.3V-5V.

 On-board indicator LED to show the results.

 On-board LM393 chip.

 SW-420 based sensor, normally closed type vibration sensor.
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 Dimension of the board: 3.2cm x 1.4cm.

 

Many Applications can create by measuring Vibration level, but sensing vibration accurately is a difficult job. This article describes about 

vibration sensor SW-420 and   Arduino interface then it may help you to design effort less vibration measurement. The vibration sensor 

SW-420 Comes with breakout board that includes comparator LM 393 and Adjustable on board potentiometer for sensitivity threshold 

selection, and signal indication LED. 

 

2.3 Software Installation: 

 

 

           

 

 

 

 

 

 

 

 

 

 

 

Step 1:  

Install the ESP8266 Board Package: 

Enterhttp://arduino.esp8266.com/stable/package_esp8266com_index.json into Additional Board Manager URLs field 

in the Arduino v1.6.4+ preferences 

Step 2:  
Click ‘File’ -> ‘Preferences’ to access this panel. Next, use the Board manager to install the ESP8266 package. 

Step 3:  
Click ‘Tools’ -> ‘Board:’ -> ‘Board Manager…’ to access this panel. Scroll down to ‘ esp8266 by ESP8266 Community’ and click 

“Install” button to install the ESP8266 library package. Once installation completed, close and re-open Arduino IDE for ESP8266 

library to take effect. 

Step 4:  

Setup ESP8266 Support: 

When you've restarted Arduino IDE, select ‘Generic ESP8266 Module’ from the ‘Tools’ -> ‘Board:’ dropdown menu. 

             Step 5: 

          Select 80 MHz as the CPU frequency (you can try160 MHz overclock later)Select ‘115200’ baud upload speed is a good place to 

start - later on you can try higher speedsbut 115200 is a good safe place to start. 

          Step 6: 

Go to your Windows ‘Device Manager’ to find out which Com Port ‘USB-Serial CH340’ is assigned to. Select the matching COM/serial 

port for your CH340 USB-Serial interface. 

Step 7: 

Flashingyour ESP8266 using Windows: Open the flasher that you just downloaded and a window should appearPress 

the button “Flash” and it should start the flashing process  immediately, showing the Module MAC address if successful connected. 

Step 8: 
After finishing this flashing process,it should appear a green circle with a check icon at lower left corner. Your ESP8266 module is now 

loaded with Node MCU firmware.Explorer 

is an IDE (Integrated Development Environment)for ESP8266 devices. It’s a multi platform IDE, can be used in any OS environment , this 

simply means that it runs on Windows, Mac OS X or Linux. 
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Supported  platforms: 

 Windows(x86, x86-64) 

 Linux(x86, x86-64, ARM soft & hard float) 

 Solaris(x86, x86-64) 

 Mac OS X(x86, x86-64, PPC, PPC64) 

This software allows you to establish a serial  send commands, and upload code and much more. communications with your   ESP8266 

module 

2.4 Thing Speak 

1) ThingSpeak Open source IoT Platform key IoT 

2) Features: 

1. Collect data in private channels 

2. Share data with public channels 

3. REST ful and MQTTAPIs 

4. MATLAB analytics and visualizations 

5. Alerts 

6. Event scheduling 

7. App integrations 

 

 

ACKNOWLEDGEMENTS 
I would like to thank to Prof. S.T.Bhoi, head of Department of Electronics and Telecommunication SIER,NASHIK who helped a lot to  

complete this work. 

 

CONCLUSION 

This project proposes a low cost earthquake alerting   system. The warning system can be provided to the recipients before the earthquake 

reaches their localities 
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